Dell System E-Support Tool Q&A

Q:运行时出现如下错误:

Dell System E-Support Tool, Version 3.7.0
@2004-2014 Dell Inc. All Rights Reserved.
Unable to continue the process, because the certificate could not be successfully validated.
For further information about Certificate validation process see “Credential-less CIMOM authentication” section of Release Notes.
To continue the process, enter Linux password and retry. Do you want to continue [y/n]? y

Please enter “root” password:
Unable to gather Chassis or Storage data. Make sure that user name, password, namespace, and port number are correct, and then retry.

A:安装sblim-sfcb
# yum list sblim-sfcb

Linux环境下运行DSET工具的常见问题FAQ

本文介绍了5个DSET工具的小技巧,测试版本是DSET3.3


FAQ 1 – DSET tool Cannot working in CentOS, Show error message “Unsupported OS type, please check

the OS support matrix”

FAQ 2 – 如何确保DSET日志中包含TTY Log?

FAQ 3 – DSET 3.3 outputs “Failed to gather Chassis/Storage data. Check the IP Address, credentials

and namespace.”

FAQ 4 – 执行DSET工具,意外退出,(再次运行时)

FAQ 5 – Installing the DSET tool on RHEL


FAQ 1 – DSET tool Can not working in CentOS/OEL, Show error message “Unsupported OS type, please check the OS support matrix”

故障现象:

[root@localhost ~]# lsb_release -a

LSB Version: :core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd:printing-4.0-noarch

Distributor ID: CentOS

Description: CentOS release 6.3 (Final)

Release: 6.3

Codename: Final

[root@localhost ~]# cat /etc/issue

CentOS release 6.3 (Final)

Kernel \r on an \m

[root@localhost ~]# ./dell-dset-3.3.0.300_x86-64.bin

Unsupported OS type, please check the OS support matrix

解决方法:

修改/etc/issue文件的”CentOS release 6.3 (Final)”行,更改成”Red Hat Enterprise Linux Server release 6.3 (Santiago)”

更改之后

[root@localhost ~]# cat /etc/issue

Red Hat Enterprise Linux Server release 6.3 (Santiago)

Kernel \r on an \m

Note:

– 如果RHEL系统环境也出现Unsupported OS type, please check the OS support matrix信息,很可能客户自行修改/etc/issue文件,修改回来即可。

– /etc/issue文件的用处,一个网络用户或通过串口登录系统上时,/etc/issue的文件内容显示在你login提示符之前。有的管理员为了安全,防止别人知道自己的系统信息,可能修改,也可能做自定义提示信息。


FAQ 2 – 确保DSET日志中包含TTY Log

在DSET的收集过程中,一定要将Do you want to enable report filtering (For more information, see the User’s Guide)的选项,选择为”n”。如果是y,所收集的DSET中,会丢失TTY日志。

Preparing DSET components to create a report. Please wait …

Choose an option:

Do you want to collect info for all hardware categories [y|n]:y

Do you want to collect info for all storage categories [y|n]:y

Do you want to collect info for all software categories [y|n]:y

Do you want to collect linux log files [y|n]:y

Do you want to collect advanced log files [y|n]:y

Do you want to store this report in a default name and location [y|n]:y

Do you want to enable report filtering (For more information, see the User’s Guide) [y|n]:n

Do you want to upload the report on request to Dell Technical Support after the report is generated [y|n]:n


FAQ 3 – DSET 3.3 outputs “Failed to gather Chassis/Storage data. Check the IP Address, credentials and namespace.”

故障现象:

收集执行建议使用以下命令,收集的信息会更完整。

[root@localhost bin]# dellsysteminfo -s 127.0.0.1 -u root -d hw,st,sw,lg,ad

Dell System E-Support Tool

@Copyright Dell Inc. 2004-2012 Version 3.3

* Gathering Chassis information…

* Gathering Storage information…

* Gathering Software information…

* Gathering Advanced Logs…

* Gathering System Summary information…

* Preparing and Compressing Report…

* Saving DSET CIM report to path: /root with report file name: DSET-Report-for-[localhost.localdomain-SvcTag-BVS9P2X-PE-R710]-on-12-28-2012-at-06.38-PM.zip


FAQ 4执行DSET工具,意外退出,再次运行时

故障现象:

[root@localhost etc]# /root/dell-dset-3.2.0.141_x64_A01.bin

Uninstall the existing Dell DSET installation by running uninstall.sh from /opt/dell/advdiags/dset location.

解决方法:

[root@localhost etc]# cd /opt/dell/advdiags/dset/

[root@localhost dset]# ./uninstall.sh

Cleaning up DSET deployed components …. [ Please wait ]


FAQ 5 – Installing the DSET tool on RHEL

安装失败故障现象:

[root@localhost etc]# /root/dell-dset-3.2.0.141_x64_A01.bin

This is a legal agreement (“Agreement”) between you, the user, and Dell Products

… …

Do you agree to the above license terms? (‘y’ for yes | ‘Enter’ to exit): y

Dell System E-Support Tool (DSET) Options:

Choose an option:

1) View DSET Release Notes

Show the latest DSET release notes

2) Create One-time Local System DSET Report

Creates DSET report in your home directory – removes DSET after report completion

3) Install/Upgrade DSET Collector and DSET CIM Provider

Permanently installs or upgrades the DSET application in this system

4) Install DSET Collector Only

Used to run collections on remote systems that have CIM broker services running

5) Install DSET CIM Provider Only

Permanently installs and starts DSET CIM Provider service on this system

6) Clear ESM Hardware Log

Clears the ESM Hardware log data from the system

Enter option (1-6) or ‘q’ to quit: 3

The Small Footprint CIM Broker (SFCB) is a network service that enables remote collection of system configuration information.

To perform the option that you selected, it is necessary to install and start this service and leave it running in background for future configuration collection

Continue installing/activating the SFCB on this system to listen for incoming collection requests from clients.

Do you want proceed [y|n]?y

Installing DSET Collector and CIM Providers on this system, Please wait …

DSET collects the Hardware data via Common Information Model Object Model(CIMOM): sblim-sfcb, which is already present on this system, Please enter the Administrator/Root password to validate the existing sblim-sfcb

Please enter “root” password: (出现以下报错信息)

Either sblim-sfcb installed on this system is not functional or the ‘root’ password entered is incorrect.!

Please check the ‘root’ password or reinstall/upgrade the sblim-sfcb from Operating System Media and try re-installing DSET

解决方法:

如果安装了中文版的RHEL, 并同时出现以上报错信息, 可先尝试停止Top-Pegasus 服务, 或者重新安装SFCB 包

[root@localhost ~]# yum install sblim-sfcb*

Loaded plugins: fastestmirror, refresh-packagekit, security

Loading mirror speeds from cached hostfile

Setting up Install Process

Resolving Dependencies

–> Running transaction check

—> Package sblim-sfcb.x86_64 0:1.3.11-0.7.14 will be updated

—> Package sblim-sfcb.x86_64 0:1.3.11-2.el6 will be an update

–> Processing Dependency: perl(LWP::UserAgent) for package: sblim-sfcb-1.3.11-2.el6.x86_64

–> Running transaction check

—> Package perl-libwww-perl.noarch 0:5.833-2.el6 will be installed

–> Processing Dependency: perl-HTML-Parser >= 3.33 for package: perl-libwww-perl-5.833-2.el6.noarch

–> Processing Dependency: perl(URI::URL) for package: perl-libwww-perl-5.833-2.el6.noarch

–> Processing Dependency: perl(URI::Heuristic) for package: perl-libwww-perl-5.833-2.el6.noarch

–> Processing Dependency: perl(URI) for package: perl-libwww-perl-5.833-2.el6.noarch

–> Processing Dependency: perl(HTML::Entities) for package: perl-libwww-perl-5.833-2.el6.noarch

–> Processing Dependency: perl(Compress::Zlib) for package: perl-libwww-perl-5.833-2.el6.noarch

–> Running transaction check

—> Package perl-Compress-Zlib.x86_64 0:2.020-127.el6 will be installed

–> Processing Dependency: perl(IO::Uncompress::Gunzip) >= 2.020 for package: perl-Compress-Zlib-2.020-127.el6.x86_64

–> Processing Dependency: perl(IO::Compress::Gzip::Constants) >= 2.020 for package: perl-Compress-Zlib-2.020-127.el6.x86_64

–> Processing Dependency: perl(IO::Compress::Gzip) >= 2.020 for package: perl-Compress-Zlib-2.020-127.el6.x86_64

–> Processing Dependency: perl(IO::Compress::Base::Common) >= 2.020 for package: perl-Compress-Zlib-2.020-127.el6.x86_64

–> Processing Dependency: perl(Compress::Raw::Zlib) >= 2.020 for package: perl-Compress-Zlib-2.020-127.el6.x86_64

—> Package perl-HTML-Parser.x86_64 0:3.64-2.el6 will be installed

–> Processing Dependency: perl(HTML::Tagset) >= 3.03 for package: perl-HTML-Parser-3.64-2.el6.x86_64

–> Processing Dependency: perl(HTML::Tagset) for package: perl-HTML-Parser-3.64-2.el6.x86_64

—> Package perl-URI.noarch 0:1.40-2.el6 will be installed

–> Running transaction check

—> Package perl-Compress-Raw-Zlib.x86_64 1:2.020-127.el6 will be installed

—> Package perl-HTML-Tagset.noarch 0:3.20-4.el6 will be installed

—> Package perl-IO-Compress-Base.x86_64 0:2.020-127.el6 will be installed

—> Package perl-IO-Compress-Zlib.x86_64 0:2.020-127.el6 will be installed

–> Finished Dependency Resolution

Dependencies Resolved


Package Arch Version Repository Size


Updating:

sblim-sfcb x86_64 1.3.11-2.el6 cdrom 443 k

Installing for dependencies:

perl-Compress-Raw-Zlib x86_64 1:2.020-127.el6 cdrom 68 k

perl-Compress-Zlib x86_64 2.020-127.el6 cdrom 43 k

perl-HTML-Parser x86_64 3.64-2.el6 cdrom 109 k

perl-HTML-Tagset noarch 3.20-4.el6 cdrom 17 k

perl-IO-Compress-Base x86_64 2.020-127.el6 cdrom 67 k

perl-IO-Compress-Zlib x86_64 2.020-127.el6 cdrom 134 k

perl-URI noarch 1.40-2.el6 cdrom 117 k

perl-libwww-perl noarch 5.833-2.el6 cdrom 387 k

Transaction Summary


Install 8 Package(s)

Upgrade 1 Package(s)

Total download size: 1.4 M

Is this ok [y/N]: y

Downloading Packages:


Total 517 kB/s | 1.4 MB 00:02

Running rpm_check_debug

Running Transaction Test

Transaction Test Succeeded

Running Transaction

Warning: RPMDB altered outside of yum.

Installing : perl-IO-Compress-Base-2.020-127.el6.x86_64 1/10

Installing : 1:perl-Compress-Raw-Zlib-2.020-127.el6.x86_64 2/10

Installing : perl-IO-Compress-Zlib-2.020-127.el6.x86_64 3/10

Installing : perl-Compress-Zlib-2.020-127.el6.x86_64 4/10

Installing : perl-HTML-Tagset-3.20-4.el6.noarch 5/10

Installing : perl-HTML-Parser-3.64-2.el6.x86_64 6/10

Installing : perl-URI-1.40-2.el6.noarch 7/10

Installing : perl-libwww-perl-5.833-2.el6.noarch 8/10

Updating : sblim-sfcb-1.3.11-2.el6.x86_64 9/10

warning: /etc/pam.d/sfcb created as /etc/pam.d/sfcb.rpmnew

warning: /etc/sfcb/sfcb.cfg created as /etc/sfcb/sfcb.cfg.rpmnew

Cleanup : sblim-sfcb-1.3.11-0.7.14.x86_64 10/10

Non-fatal POSTUN scriptlet failure in rpm package sblim-sfcb

Verifying : perl-Compress-Zlib-2.020-127.el6.x86_64 1/10

Verifying : perl-libwww-perl-5.833-2.el6.noarch 2/10

Verifying : 1:perl-Compress-Raw-Zlib-2.020-127.el6.x86_64 3/10

Verifying : perl-IO-Compress-Zlib-2.020-127.el6.x86_64 4/10

Verifying : perl-IO-Compress-Base-2.020-127.el6.x86_64 5/10

Verifying : perl-URI-1.40-2.el6.noarch 6/10

Verifying : perl-HTML-Tagset-3.20-4.el6.noarch 7/10

Verifying : sblim-sfcb-1.3.11-2.el6.x86_64 8/10

Verifying : perl-HTML-Parser-3.64-2.el6.x86_64 9/10

Verifying : sblim-sfcb-1.3.11-0.7.14.x86_64 10/10

Dependency Installed:

perl-Compress-Raw-Zlib.x86_64 1:2.020-127.el6 perl-Compress-Zlib.x86_64 0:2.020-127.el6 perl-HTML-Parser.x86_64 0:3.64-2.el6 perl-HTML-Tagset.noarch 0:3.20-4.el6

perl-IO-Compress-Base.x86_64 0:2.020-127.el6 perl-IO-Compress-Zlib.x86_64 0:2.020-127.el6 perl-URI.noarch 0:1.40-2.el6 perl-libwww-perl.noarch 0:5.833-2.el6

Updated:

sblim-sfcb.x86_64 0:1.3.11-2.el6

Complete!

发表评论